Skip to main content
← All vulnerabilities
CVE-2025-47943GO-2025-3778GHSA-XH32-CX6C-CP4V

Gogs stored XSS in PDF renderer

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 0.13.3-0.20250608224432-110117b2e5e5
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: poc
  • Automatable: no
  • Technical impact: partial

Summary

Gogs is an open source self-hosted Git service. In application version 0.14.0+dev and prior, there is a stored cross-site scripting (XSS) vulnerability present in Gogs, which allows client-side Javascript code execution. The vulnerability is caused by the usage of a vulnerable and outdated component: pdfjs-1.4.20 under public/plugins/. This issue has been fixed for gogs.io/gogs in version 0.13.3.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: poc · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • gogs gogs

    through 0.14.0+dev

  • gogs.io/gogsGo

    fixed in 0.13.3-0.20250608224432-110117b2e5e5

  • github.com/gogs/gogsGo

    fixed in 0.13.3-0.20250608224432-110117b2e5e5

References 4

GitHub · gogs/gogs

hacktivesecurity.com