Skip to main content
← All vulnerabilities
CVE-2025-47940GHSA-6FRX-J292-C844

TYPO3 CMS Vulnerable to Privilege Escalation to System Maintainer

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 10.4.50, 11.5.44, 12.4.31, 13.4.12
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: total

Summary

TYPO3 is an open source, PHP based web content management system. Starting in version 10.0.0 and prior to versions 10.4.50 ELTS, 11.5.44 ELTS, 12.4.31 LTS, and 13.4.12 LTS, administrator-level backend users without system maintainer privileges can escalate their privileges and gain system maintainer access. Exploiting this vulnerability requires a valid administrator account. Users should update to TYPO3 version 10.4.50 ELTS, 11.5.44 ELTS, 12.4.31 LTS, or 13.4.12 LTS to fix the problem.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: total

  3. Record last updated

Affected versions

  • TYPO3 typo3

    From 10.0.0 · fixed in 10.4.50; From 11.0.0 · fixed in 11.5.44; From 12.0.0 · fixed in 12.4.31; From 13.0.0 · fixed in 13.4.12

  • typo3/cms-corePackagist

    From 10.4.0 · fixed in 10.4.50

  • typo3/cms-corePackagist

    From 11.0.0 · fixed in 11.5.44

  • typo3/cms-corePackagist

    From 12.0.0 · fixed in 12.4.31

  • typo3/cms-corePackagist

    From 13.0.0 · fixed in 13.4.12

References 2

GitHub · TYPO3/typo3

typo3.org