Skip to main content
← All vulnerabilities
CVE-2025-47936GHSA-P4XX-M758-3HPX

TYPO3 Vulnerable to Server Side Request Forgery via Webhooks

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 12.4.31, 13.4.12
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

TYPO3 is an open source, PHP based web content management system. In versions on the 12.x branch prior to 12.4.31 LTS and the 13.x branch prior to 13.4.2 LTS, Webhooks are inherently vulnerable to Cross-Site Request Forgery (CSRF), which can be exploited by adversaries to target internal resources (e.g., localhost or other services on the local network). While this is not a vulnerability in TYPO3 itself, it may enable attackers to blindly access systems that would otherwise be inaccessible. An administrator-level backend user account is required to exploit this vulnerability. Users should update to TYPO3 version 12.4.31 LTS or 13.4.12 LTS to fix the problem.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • TYPO3 typo3

    From 12.0.0 · fixed in 12.4.31; From 13.0.0 · fixed in 13.4.12

  • typo3/cms-webhooksPackagist

    From 12.0.0 · fixed in 12.4.31

  • typo3/cms-webhooksPackagist

    From 13.0.0 · fixed in 13.4.12

References 2

GitHub · TYPO3/typo3

typo3.org