Skip to main content
← All vulnerabilities
CVE-2025-47705DRUPAL-CONTRIB-2025-051

IFrame Remove Filter - Moderately critical - Cross site scripting - SA-CONTRIB-2025-051

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.0.5
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Drupal IFrame Remove Filter allows Cross-Site Scripting (XSS).This issue affects IFrame Remove Filter: from 2.0.0 before 2.0.5, from 7.X-1.0 through 7.X-1.5, from 1.0 through 1.2.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • Drupal IFrame Remove Filter

    From 7.x-1.0 · through 7.x-1.5; From 1.0 · through 1.2; From 2.0.0 · fixed in 2.0.5

  • drupal/iframeremovePackagist

    fixed in 2.0.5

References 2

drupal.org

herodevs.com