Skip to main content
← All vulnerabilities
CVE-2025-47410GHSA-GJP8-99FV-CGCW

Apache Geode: CSRF attacks through GET requests to the Management and Monitoring REST API that can execute gfsh commands on the target system

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 1.15.2
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: total

Summary

Apache Geode is vulnerable to CSRF attacks through GET requests to the Management and Monitoring REST API that could allow an attacker who has tricked a user into giving up their Geode session credentials to submit malicious commands on the target system on behalf of the authenticated user. This issue affects Apache Geode: versions 1.10 through 1.15.1 Users are recommended to upgrade to version 1.15.2, which fixes the issue.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: total

  3. Record last updated

Affected versions

  • org.apache.geode:geode-web

    From 1.10.0 · fixed in 1.15.2

  • org.apache.geode:geode-webMaven

    From 1.10.0 · fixed in 1.15.2

References 1

lists.apache.org