Skip to main content
← All vulnerabilities
CVE-2025-47284GHSA-9X73-87FH-54W9GO-2025-3698

Gardener vulnerable to metadata injection for a project secret that can lead to privilege escalation

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 1.116.4, 1.117.5, 1.118.2
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: total

Summary

Gardener implements the automated management and operation of Kubernetes clusters as a service. A security vulnerability was discovered in the `gardenlet` component of Gardener prior to versions 1.116.4, 1.117.5, 1.118.2, and 1.119.0. It could allow a user with administrative privileges for a Gardener project to obtain control over the seed cluster(s) where their shoot clusters are managed. This CVE affects all Gardener installations where gardener/gardener-extension-provider-gcp is in use. Versions 1.116.4, 1.117.5, 1.118.2, and 1.119.0 fix the issue.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: total

  3. Record last updated

Affected versions

  • gardener gardener

    fixed in 1.116.4; From 1.117.0 · fixed in 1.117.5; From 1.118.0 · fixed in 1.118.2

  • github.com/gardener/gardenerGo

    fixed in 1.116.4

  • github.com/gardener/gardenerGo

    From 1.117.0 · fixed in 1.117.5

  • github.com/gardener/gardenerGo

    From 1.118.0 · fixed in 1.118.2

  • github.com/gardener/gardenerGo

    fixed in 1.116.4; From 1.117.0 · fixed in 1.117.5; From 1.118.0 · fixed in 1.118.2

References 1

GitHub · gardener/gardener