Skip to main content
← All vulnerabilities
CVE-2025-47110GHSA-J934-VJH5-VF9R

Adobe Commerce | Cross-site Scripting (Stored XSS) (CWE-79)

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.4.8-p1, 2.4.7-p6, 2.4.5-p13, 2.4.6-p11
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: total

Summary

Adobe Commerce versions 2.4.8, 2.4.7-p5, 2.4.6-p10, 2.4.5-p12, 2.4.4-p13 and earlier are affected by a stored Cross-Site Scripting (XSS) vulnerability that could be abused by a high-privileged attacker to inject malicious scripts into vulnerable form fields. Malicious JavaScript may be executed in a victim’s browser when they browse to the page containing the vulnerable field. Scope is changed to that of other high-privileged accounts, leading to a high impact on confidentiality, integrity, and availability.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: total

  3. Record last updated

Affected versions

  • Adobe Adobe Commerce

    through 2.4.4-p13

  • magento/community-editionPackagist

    From 2.4.8-beta1 · fixed in 2.4.8-p1

  • magento/community-editionPackagist

    From 2.4.7-beta1 · fixed in 2.4.7-p6

  • magento/community-editionPackagist

    fixed in 2.4.5-p13

  • magento/community-editionPackagist

    2.4.7

  • magento/community-editionPackagist

    2.4.8

  • magento/community-editionPackagist

    2.4.5

  • magento/community-editionPackagist

    From 2.4.6-p1 · fixed in 2.4.6-p11

  • magento/community-editionPackagist

    2.4.6

References 1

helpx.adobe.com