Skip to main content
← All vulnerabilities
CVE-2025-46701GHSA-H2FW-RFH5-95R3BIT-TOMCAT-2025-46701

Apache Tomcat: Security constraint bypass for CGI scripts

Published
Last modified
published
Not listed in CISA KEV
Low (apache)
Fix
Fixed in 9.0.105, 10.1.41, 11.0.7
1 proof of concept on GitHub
  • Exploitation: none
  • Automatable: yes
  • Technical impact: partial

Summary

Improper Handling of Case Sensitivity vulnerability in Apache Tomcat's GCI servlet allows security constraint bypass of security constraints that apply to the pathInfo component of a URI mapped to the CGI servlet. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.6, from 10.1.0-M1 through 10.1.40, from 9.0.0.M1 through 9.0.104. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.0 though 8.5.100. Other, older, EOL versions may also be affected. Users are recommended to upgrade to version 11.0.7, 10.1.41 or 9.0.105, which fixes the issue.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: yes · Technical impact: partial

  3. Record last updated

Affected versions

  • Apache Software Foundation Apache Tomcat

    From 11.0.0-M1 · through 11.0.6; From 10.1.0-M1 · through 10.1.40; From 9.0.0.M1 · through 9.0.104; From 8.5.0 · through 8.5.100

  • org.apache.tomcat:tomcat-catalinaMaven

    From 9.0.0.M1 · fixed in 9.0.105

  • org.apache.tomcat:tomcat-catalinaMaven

    From 10.1.0-M1 · fixed in 10.1.41

  • org.apache.tomcat:tomcat-catalinaMaven

    From 11.0.0-M1 · fixed in 11.0.7

  • org.apache.tomcat.embed:tomcat-embed-coreMaven

    From 9.0.0.M1 · fixed in 9.0.105

  • org.apache.tomcat.embed:tomcat-embed-coreMaven

    From 10.1.0-M1 · fixed in 10.1.41

  • org.apache.tomcat.embed:tomcat-embed-coreMaven

    From 11.0.0-M1 · fixed in 11.0.7

  • org.apache.tomcat:tomcat-catalinaMaven

    From 8.5.0 · through 8.5.100

  • org.apache.tomcat.embed:tomcat-embed-coreMaven

    From 8.5.0 · through 8.5.100

References 2

lists.apache.org

GitHub · gregk4sec/CVE-2025-46701-o