Skip to main content
← All vulnerabilities
CVE-2025-43819GHSA-RPX3-F938-XJ5Q

A Insufficient Session Expiration vulnerability in the Liferay Portal 7.4.3.121 through 7.3.3.131, and Liferay DXP 2024.Q4.0 through 2024.Q4

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 5.0.51
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

A Insufficient Session Expiration vulnerability in the Liferay Portal 7.4.3.121 through 7.3.3.131, and Liferay DXP 2024.Q4.0 through 2024.Q4.3, 2024.Q3.1 through 2024.Q3.13, 2024.Q2.0 through 2024.Q2.13, and 2024.Q1.1 through 2024.Q1.12 is allow an remote non-authenticated attacker to reuse old user session by SLO API

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • Liferay Portal

    From 7.4.3.121 · through 7.4.3.131

  • Liferay DXP

    From 2024.Q1.1 · through 2024.Q1.12; From 2024.Q2.0 · through 2024.Q2.13; From 2024.Q3.1 · through 2024.Q3.13; From 2024.Q4.0 · through 2024.Q4.3

  • com.liferay:com.liferay.saml.implMaven

    fixed in 5.0.51

References 1

liferay.dev