Skip to main content
← All vulnerabilities
CVE-2025-43585GHSA-R487-9VV5-75GG

Adobe Commerce | Improper Authorization (CWE-285)

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.4.7-p6, 2.4.6-p11, 2.4.5-p13
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

Adobe Commerce versions 2.4.8, 2.4.7-p5, 2.4.6-p10, 2.4.5-p12, 2.4.4-p13 and earlier are affected by an Improper Authorization vulnerability that could result in a Security feature bypass. An attacker could leverage this vulnerability to bypass security measures and gain unauthorized access leading to a limited impact to confidentiality and a high impact to integrity. Exploitation of this issue does not require user interaction.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • Adobe Adobe Commerce

    through 2.4.4-p13

  • magento/project-community-editionPackagist

    through 2.0.2

  • magento/community-editionPackagist

    From 2.4.7-beta1 · fixed in 2.4.7-p6

  • magento/community-editionPackagist

    From 2.4.6-p1 · fixed in 2.4.6-p11

  • magento/community-editionPackagist

    fixed in 2.4.5-p13

  • magento/community-editionPackagist

    2.4.5

  • magento/community-editionPackagist

    2.4.6

  • magento/community-editionPackagist

    2.4.7

  • magento/community-editionPackagist

    2.4.8

References 1

helpx.adobe.com