Skip to main content
← All vulnerabilities
CVE-2025-4207

PostgreSQL GB18030 encoding validation can read one byte past end of allocation for text that fails validation

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 17.5, 16.9, 15.13, 14.18, 13.21
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

Buffer over-read in PostgreSQL GB18030 encoding validation allows a database input provider to achieve temporary denial of service on platforms where a 1-byte over-read can elicit process termination. This affects the database server and also libpq. Versions before PostgreSQL 17.5, 16.9, 15.13, 14.18, and 13.21 are affected.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • n/a PostgreSQL

    From 17 · fixed in 17.5; From 16 · fixed in 16.9; From 15 · fixed in 15.13; From 14 · fixed in 14.18; fixed in 13.21

References 1

postgresql.org