Skip to main content
← All vulnerabilities
CVE-2025-41423GO-2025-3644GHSA-FR22-5377-F3P7

Unauthorized Playbooks Post Deletion in Mattermost Playbooks Plugin

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 1.41.0, 8.0.0-20250218121836-2b5275d87136
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

Mattermost versions 10.4.x <= 10.4.2, 10.5.x <= 10.5.0, 9.11.x <= 9.11.10 fail to properly validate permissions for the API endpoint /plugins/playbooks/api/v0/signal/keywords/ignore-thread, allowing any user or attacker to delete posts containing actions created by the Playbooks bot, even without channel access or appropriate permissions.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • Mattermost Mattermost

    From 10.4.0 · through 10.4.2; From 9.11.0 · through 9.11.10

  • github.com/mattermost/mattermost-plugin-playbooksGo

    All versions

  • github.com/mattermost/mattermost-plugin-playbooksGo

    fixed in 1.41.0

  • github.com/mattermost/mattermost-serverGo

    From 9.11.0+incompatible

  • github.com/mattermost/mattermost-serverGo

    From 10.4.0+incompatible

  • github.com/mattermost/mattermost-serverGo

    From 10.5.0+incompatible

  • github.com/mattermost/mattermost-server/v5Go

    All versions

  • github.com/mattermost/mattermost-server/v6Go

    All versions

  • github.com/mattermost/mattermost/server/v8Go

    All versions

  • github.com/mattermost/mattermost/server/v8Go

    fixed in 8.0.0-20250218121836-2b5275d87136

  • github.com/mattermost/mattermost-plugin-playbooksGo

    From 2.0.0

  • github.com/mattermost/mattermost/server/v8Go

    From 10.4.0

  • github.com/mattermost/mattermost/server/v8Go

    From 10.5.0

  • github.com/mattermost/mattermost/server/v8Go

    From 9.11.0

References 1

mattermost.com