Skip to main content
← All vulnerabilities
CVE-2025-41395GHSA-3G36-GF7C-75QWGO-2025-3642

Webapp DoS via malicious retrospective post in Playbooks

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 8.0.0-20250218121836-2b5275d87136, 1.41.0
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

Mattermost versions 10.4.x <= 10.4.2, 10.5.x <= 10.5.0, 9.11.x <= 9.11.10 fail to properly validate the props used by the RetrospectivePost custom post type in the Playbooks plugin, which allows an attacker to create a specially crafted post with maliciously crafted props and cause a denial of service (DoS) of the web app for all users.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • Mattermost Mattermost

    From 10.4.0 · through 10.4.2; From 9.11.0 · through 9.11.10

  • github.com/mattermost/mattermost-plugin-playbooksGo

    From 2.0.0

  • github.com/mattermost/mattermost/server/v8Go

    fixed in 8.0.0-20250218121836-2b5275d87136

  • github.com/mattermost/mattermost/server/v8Go

    From 10.4.0

  • github.com/mattermost/mattermost/server/v8Go

    From 10.5.0

  • github.com/mattermost/mattermost/server/v8Go

    From 9.11.0

  • github.com/mattermost/mattermost-plugin-playbooksGo

    fixed in 1.41.0

  • github.com/mattermost/mattermost-plugin-playbooksGo

    All versions

  • github.com/mattermost/mattermost-serverGo

    From 9.11.0+incompatible

  • github.com/mattermost/mattermost-serverGo

    From 10.4.0+incompatible

  • github.com/mattermost/mattermost-serverGo

    From 10.5.0+incompatible

  • github.com/mattermost/mattermost-server/v5Go

    All versions

  • github.com/mattermost/mattermost-server/v6Go

    All versions

  • github.com/mattermost/mattermost/server/v8Go

    All versions

References 1

mattermost.com