Skip to main content
← All vulnerabilities
CVE-2025-3901DRUPAL-CONTRIB-2025-042

Bootstrap Site Alert - Moderately critical - Cross Site Scripting - SA-CONTRIB-2025-042

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 1.13.0, 3.0.4
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Drupal Bootstrap Site Alert allows Cross-Site Scripting (XSS).This issue affects Bootstrap Site Alert: from 0.0.0 before 1.13.0, from 3.0.0 before 3.0.4.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • Drupal Bootstrap Site Alert

    From 0.0.0 · fixed in 1.13.0; From 3.0.0 · fixed in 3.0.4

  • drupal/bootstrap_site_alertPackagist

    fixed in 1.13.0; From 3.0.0 · fixed in 3.0.4

References 1

drupal.org