CVE-2025-37731GHSA-M9GH-789G-Q5PVBIT-ELASTICSEARCH-2025-37731
Elasticsearch Improper Authentication
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 8.19.8, 9.1.8, 9.2.2
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
CISA's decision points: whether it is exploited, whether attacks can be automated, and how much control an attacker gets. Assessed (SSVC 2.0.3).What do these mean? →
- Exploitation: none
- Automatable: no
- Technical impact: total
Summary
Improper Authentication in Elasticsearch PKI realm can lead to user impersonation via specially crafted client certificates. A malicious actor would need to have such a crafted client certificate signed by a legitimate, trusted Certificate Authority.
Timeline
- CVE published
- CISA SSVC assessment
Exploitation: none · Automatable: no · Technical impact: total
- Record last updated
Affected versions
- Elastic Elasticsearch
From 7.0.0 · through 7.17.29; From 8.0.0 · through 8.19.7; From 9.0.0 · through 9.1.7; From 9.2.0 · through 9.2.1
- org.elasticsearch.plugin:x-pack-securityMaven
From 7.0.0-alpha1 · fixed in 8.19.8
- org.elasticsearch.plugin:x-pack-securityMaven
From 9.0.0-beta1 · fixed in 9.1.8
- org.elasticsearch.plugin:x-pack-securityMaven
From 9.2.0 · fixed in 9.2.2
- org.elasticsearch.plugin:x-pack-coreMaven
From 7.0.0-alpha1 · fixed in 8.19.8
- org.elasticsearch.plugin:x-pack-coreMaven
From 9.0.0-beta1 · fixed in 9.1.8
- org.elasticsearch.plugin:x-pack-coreMaven
From 9.2.0 · fixed in 9.2.2